روتر چیست و چگونه کار می کند؟

  • -

روتر چیست و چگونه کار می کند؟

روتر چیست و چگونه کار می کند؟

روتر چیست و چگونه کار می کند؟
در دنیای امروزه ارتباط در دنیای مجازی اینترنت امری رایج است. اینترنت به کاربران این اجازه را می‌دهد که در کسری از ثانیه از سراسر دنیا برای یکدیگر ایمیل بفرستند و به راحتی از بین میلیون‌ها مطلب مختلف به مطالعه مقالات مورد نظر بپردازند. مطمئنا شما بارها با موضوعات مختلفی از قبیل صفحات وب، ایمیل‌ها و فایل‌ها که از طریق اینترنت ارسال می‌شوند مواجه شده اید. اما هیچ یک از فعالیت‌هایی که شما در اینترنت انجام می‌دهید بدون روتر امکان پذیر نخواهد بود. در واقع تمام هستی شبکه به وجود روتر بستگی دارد، در حالیکه بیشتر مردم اصلا با این ماشین تکنولوژی از نزدیک مواجه نشده‌اند.

 

روتر  (Router)

 روترها کامپیوترهای اختصاصی هستند که پیغام‌های شما و دیگر کاربران اینترنت را در امتداد هزاران مسیر به سرعت به سوی مقصدشان روانه می‌کنند. در این زنگ تفریح  به این ماشین‌ها که در پشت صحنه باعث کارکردن اینترنت هستند نگاهی می‌اندازیم.
در حرکت نگاه داشتن پیغام‌ها
 هنگامیکه شما ایمیل برای دوستتان در آن طرف دنیا می‌فرستید، پیغام چگونه می‌داند در کامپیوتر دوست شما به مسیر خود خاتمه دهد نه در میلیونها کامپیوتر دیگر در سرتاسر دنیا؟ اکثر کار مربوط به رساندن از کامپیوتری به کامپیوتر دیگر توسط روترها انجام می‌گیرد، زیرا آنها وسایل اختصاصی جهت رساندن پیام‌ها از یک شبکه به شبکه دیگر به جای جریان در یک شبکه هستند.
بیایید به کاری که یک روتر خیلی ساده انجام می‌دهد نگاهی بیندازیم. شرکت کوچکی را در نظر بگیرید که انیمیشن‌های سه بعدی برای ایستگاه‌های تلویزیون محلی می‌سازد. شرکت ده کارمند دارد که هر کدام دارای یک کامپیوتر هستند، چهار کارمند انیماتورند و بقیه در قسمت‌های فروش، حسابداری و مدیریت کار می‌کنند. انیماتورها اغلب در مواردی که بر روی یک پروژه کار می کنند نیاز به ارسال فایل‌های حجیم برای یکدیگر دارند. برای این منظور آنها از شبکه استفاده می کنند. وقتیکه یکی از انیماتورها فایلی را برای انیماتور دیگر می فرستد، فایل بزرگ از اکثر ظرفیت شبکه استفاده خواهد نمود و باعث می شود شبکه برای کاربران دیگر بسیار کند گردد. یکی از دلایلی که یک کاربر می تواند تمامی شبکه را تحت تاثیرقرار دهد، نتیجه طریقی است که اترنت کار می کند. هر بسته اطلاعاتی که از کامپیوتری فرستاده می شود توسط تمام کامپیوترهای دیگر در آن شبکه محلی دیده می شود، سپس هر کامپیوتر بسته را امتحان می کند و تصمیم می‌گیرد که آیا منظور آدرس او بوده است یا نه. این موضوع طرح مقدماتی شبکه را ساده می کند اما دارای پیامدهایی در کارایی هنگامی‌که اندازه و میزان فعالیت شبکه افزایش می یابد است. برای جلوگیری از تداخل کار انیماتورها با افرادی که در قسمت‌های دیگر اداره کار می‌کنند، کمپانی دو شبکه مجزا احداث می‌کند، یکی برای انیماتورها و یکی برای بقیه شرکت. یک روتر دو شبکه را به هم متصل کرده و هر دو را به اینترنت وصل می کند.
روتر تنها وسیله‌ای است که هر پیغامی که به وسیله هر کامپیوتری در هر یک از شبکه‌های شرکت ارسال می‌شود را می‌بیند. وقتی یکی از انیماتورها فایل عظیمی را برای انیماتور دیگر می‌فرستد، روتر به آدرس گیرنده نگاه می کند و تراقیک را در شبکه انیماتورها نگاه می‌دارد. از طرف دیگر وقتی یکی از انیماتورها پیغامی به دفتردار می‌فرستد و درخواست چک کردن صورت هزینه را می‌دهد، روتر آدرس گیرنده را می بیند و پیغام را بین دو شبکه ارسال می‌کند.
یکی از چیزهایی که روتر جهت تصمیم گیری در مورد اینکه یک بسته کجا باید برود استفاده می کند جدول تنظیمات (Configuration Table)  است. جدول تنظیمات مجموعه ای از اطلاعات می باشد، شامل موارد زیر:
•   اطلاعاتی درباره آنکه چه اتصالاتی به چه گروهی از آدرس‌ها مرتبط می شوند.
 •  تقدم مربوط به ارتباطات مورد استفاده.
 •  قوانینی برای مدیریت حالت‌های عادی و خاص ترافیک
جدول تنظیمات در ساده ترین روترها می‌تواند دارای چندین سطر باشد و در روترهای بزرگ که مدیریت پیام‌ها را در ستون فقرات اینترنت بر عهده دارند پیچیدگی و بزرگی آن بسیار بیشتر خواهد شد. پس روتر دو کار جداگانه اما مرتبط با هم دارد:
•  روتر مطمئن می شود که اطلاعات به جایی که نیاز نیست نمی رود. این امر برای جلوگیری از انباشته شدن مقادیر زیادی اطلاعات نامربوط در اتصالات کاربران امری حیاتی است.
 •  روتر اطمینان حاصل می کند که اطلاعات به مقصد مورد نظر می رسد.
 با توجه به این دو وظیفه، روتر وسیله ای بسیار مفید جهت کار  با دو شبکه مجزا است. روتر دو شبکه را به هم متصل می‌کند، اطلاعات را از یکی به دیگری می‌فرستد و در برخی موارد پروتکل‌های مختلف بین دو شبکه را ترجمه می‌کند. همچنین از شبکه ها در برابر همدیگر محافظت می کند و از رسیدن ترافیک غیر جلوگیری می‌کند. همچنانکه تعداد شبکه های متصل به هم بیشتر باشد، جدول تنظیمات برای اداره کردن ترافیک بین آنهاگسترده‌تر است و قدرت پردازش روتر بیشتر است. صرفنظر از تعداد شبکه هایی که متصل شده اند، کار اصلی و وظیفه روتر به همان صورت اصلی باقی می ماند.
انواع روترها :
روترهای سخت افزاری: این روترها، سخت افزارهای هستند که نرم افزارهای خاص تولید شده توسط تولید کنندگان را اجرا می‌نمایند
. این نرم افزارها ، قابلیت روتینگ را برای روترها فراهم نموده تا آنان مهمترین و شاید ساده‌ترین وظیفه خود که ارسال داده از یک شبکه به شبکه دیگر است را بخوبی انجام دهند. اکثر شرکت‌ها ترجیح می‌دهند که از روترهای سخت افزاری استفاده نمایند چراکه آنان در مقایسه با روترهای نرم افزاری، دارای سرعت و اعتماد پذیری بیشتری هستند. شکل زیر یک نمونه روتر را نشان می دهد
Cisco 2600 Series Multiservice Platform
روترهای نرم افزاری: روترهای نرم افزاری دارای عملکردی مشابه با روترهای سخت افزاری بوده و مسئولیت اصلی آنان نیز ارسال داده از یک شبکه به شبکه دیگر است.
در اکثر موارد از روترها به عنوان فایروال و یا gateway اینترنت، استفاده می‌گردد. اما روترهای نرم افزاری و سخت افزاری با هم متفاوتند، در اکثر موارد نمی توان یک روتر نرم افزاری را جایگزین یک روتر سخت افزاری نمود، چراکه روترهای سخت افزاری دارای سخت افزار لازم و از قبل تعبیه شده‌ای می باشند که به آن ها امکان اتصال به یک لینک خاص مثل ATM را خواهد داد. یک روتر نرم افزاری ( نظیر سرویس دهنده ویندوز ) دارای تعدادی کارت شبکه است که هر یک از آن‌ها به یک شبکه LAN متصل شده و سایر اتصالات به شبکه های WAN از طریق روترهای سخت افزاری، انجام خواهد شد.
مهمترین ویژگی یک روتر :
  روترها تا زمانی‌که  برنامه‌ریزی نشوند، نمی‌توانند داده‌ها را توزیع کنند. اکثر روترهای مهم دارای سیستم عامل اختصاصی خاص خود هستند. روترها از پروتکل‌های خاصی به منظور مبادله اطلاعات ضروری خود، استفاده می‌کنند. نحوه عملکرد یک روتر در اینترنت به این صورت است که مسیر ایجاد شده برای انجام مبادله اطلاعاتی بین سرویس‌گیرنده و سرویس دهنده در تمامی مدت زمان انجام تراکش ثابت و یکسان نیست و متناسب با وضعیت ترافیک موجود و در دسترس بودن مسیر، تغییر می‌کند.

  • ۰

راه اندازی SSH در سیسکو

راه اندازی SSH در سیسکو

راه اندازی SSH در سیسکو

راه اندازی SSH در سیسکو

یکی از متداولترین روش های اتصال به سخت افزارهای سیسکو استفاده از پروتکل telnet می باشد. حتما با telnet آشنایی دارید.
یک پروتکل که عموما برای مدیریت و کنترل سخت افزار ها از راه دور استفاده می شود. این پروتکل اطلاعات را به صورت clear text میان سرور و کلاینت عبور میدهد, که این امر باعث نا امنی زیادی می شود. چرا که به راحتی می توان با قرار دادن یک Packet capture مانند Wireshark تمامی Packet های عبوری را مشاهده و از اطلاعات آن سو استفاده کرد. البته روشهایی برای امن کردن آن مانند دسترسی تنها چند کامپیوتر خاص به telnet وجود دارد. اما باز هم نمیتوان امنیت آن را تضمین کرد.
یک راه حل مفید برای جایگزینی telnet استفاده از پروتکل SSH است. SSH یا Secure Shell پروتکلی است که اطلاعات را به صورت کد شده میان سرور و کلاینت رد و بدل میکند.
به صورت پیش فرض این پروتکل در روتر ها و سوئیچ های سیسکو غیر فعال است.
این جدول نشان دهنده IOS ها و سخت افزارهایی است که از پروتکل SSH پشتیبانی میکنند.

Router IOS

C1700      12.1(1) and later

C2600      12.1(1) and later

C3600      12.1(1) and later

C7200      12.1(1) and later

C7500      12.1(1) and later

Ubr920     12.1(1) and later

 

CatOS SSH
Cat 4000/4500/2948G/2980G (CatOS)                K9 images as of 6.1

Cat 5000/5500 (CatOS)                                     K9 images as of 6.1

Cat 6000/6500 (CatOS)                                     K9 images as of 6.1

Cat 2950                                                         12.1(12c)EA1 and later

Cat 3550*                                                       12.1(11)EA1 and later

Cat 4000/4500 (Integrated Cisco IOS Software)   12.1(13)EW and later

Cat 6000/5500 (Integrated Cisco IOS Software)   12.1(11b)E and later

Cat 8540/8510                                                 12.1(12c)EY and later, 12.1(14)E1 and later

 

NO SSH Support

Cat 1900                  no
Cat 2800                  no
Cat 2948G-L3            no
Cat 2900XL               no
Cat 3500XL               no
Cat 4840G-L3            no
Cat 4908G-L3            no

برای فعال سازی SSH ابتدا میبایست hostname و domain name را مشخص کنیم:

  • تغییرhostname
Router(config)#hostname PersianAdmins

 

  • مشخص کردنdomain name
vCenter(config)#ip domain-name router1.vcenter.ir

 

  • حالا باید یک RSA key pair برای روتر خود تولید کنیم. که با تولید این کلید به طور اتوماتیک SSH بر روی روتر شما فعال خواهد شد.
vCenter(config)#crypto key generate rsa

 

‏IOS از شما خواهد پرسید که طول این کلید چند بیتی باشد. که میتوانید از 360 تا 2048 انتخاب کنید. پیش فرض آن 512 است که توصیه میشود از کلید 1024 بیتی استفاده نمائید.
هم اکنون SSH بر روی روتر شما فعال است و میتوانید بوسیله نرم افزارهای مانند Putty به آن متصل شوید.
لینک دانلود putty:

 

http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe

 

شما میتوانید بعضی از تنظیمات مانند مدت زمان تبادل کلید ( بین SSH Server و SSH Client ) و تعداد دفعات تلاش برای وارد کردن username و Password را مشخص کنید. مدت زمان تبادل کلید ماگزیمم 120 ثانیه است که به صورت پیش فرض همان 120 ثانیه تنظیم گردیده و تعداد دفعات تلاش برای login 5 دفعه که به صورت پیش فرض 3 دفعه تعیین گردیده است.

vCenter(config)#ip ssh timeout 100
vCenter(config)#ip ssh authentication-retries 4

 

با دستور زیر هم میتوان اینترفیسی که کانکشن SSH به آن وارو میشود را مشخص کرد:

vCenter(config)#ip ssh source-interface f0/1

و برای log بر داشتن از کانکشن های SSH :

 

vCenter(config)#ip ssh logging events

 

برای غیر فعال نمودن SSH میتوانید از این دستور استفاده کنید:

 

vCenter(config)#crypto key zeroize rsa

 

شما میتوانید با دستور زیر وضعیت SSH را چک کنید:

 

vCenter#show ip ssh

 

برای مشاهده لیست کانکشن های متصل با SSH

 

vCenter#show ssh

 

بقیه تنظیمات SSH از تنظیمات  line vty 0 4 پیروی میکند. تنظیماتی مانند مدت زمان هر کانکشن که پیش فرض در صورت Idle بودن 10 دقیقه است و ماکزیمم 5 کانکشن همزمان پشتیبانی میکند.
ممکن است شما نیاز به مدت زمان زیادی برای باز بودن یک کانشن دارید. حتی اگر استفاده ای از آن نشود و از هر 10 دقیقه یکبار از وارد کردن Username و Password رنج میبرید. میتوانید با این دستور مدت زمان آن را زیاد کنید اما توجه داشته باشید که این کار از لچاظ امنیتی توصیه نمی شود:

vCenter(config)#line vty 0 4
vCenter(config-line)#exec-timeout 35

 

که این عدد میتوانید بین 0 تا 35791 دقیقه باشد.
در بعضی شبکه ها شما دارای تعداد زیادی روتر و سوئیچ هستید که میبایست با تمامی آنها کار کنید. اینجا یک مشکل به وجود می آید. اگر شما پسورد های مختلف روی آنها قرار بدید به خاطر سپردن آنها خیلی سخت خواهد بود و اگر همه را یکسان بگذارید از لحاظ امنیتی دچار مشکل خواهید شد. چرا که در صورت لو رفتن پسورد یک روتر شما تمامی روترهای خود را از دست خواهید داد.
برای حل این مشکل میتوانیم از یک Radius server استفاده کنیم. Radius دارای یک دیتا بیس است که لیست یوزرهای ما , مشخصات و صفات آنها در آن ثبت میشود. وقتی شما سعی میکنید که به یک روتر متصل شوید آن روتر یوزر و پسورد شما را به Radius میفرستد. اگر آنها درست بودند یک پیغام از Radius به روتر فرستاده میشود و روتر به شمااجازه ورود می دهد. که این کار مزایای دیگری نیز دارد.

  • شما میتوانید زمان ورود و خروج کاربران مختلف را ثبت کنید
  • تنها یک پسورد به خاطر می سپارید
  • میتوانید برای ورود به روتر زمان مشخص کنید
  • سطح دسترسی هر یوزر به روتر قابل کنترل است
  • با یکبار عوض کردن پسورد در تمامی روتر ها پسورد شما عوض خواهد شد

ابتدا میبایست مشخص کنیم که چه درخواست هایی به Radius فرستاده شود

 

vCenter(config)#aaa new-model
vCenter(config)#aaa authentication login shahin group radius local
vCenter(config)#aaa authentication enable default group radius

 

در خط دوم مشخص کرده ایم که چک کردن یوزر و پسورد ورود به روتر به radius برود اگر radius نبود از میان یوزرهای ساخته شده داخل خود روتر چک کند. ما میتوانیم متد های مختلف برای هر اکانتینگ  داشته باشیم. اگر بجای واژه shahin بنویسیم default آنگاه این دستور برای تمامی اینترفیس ها اعمال میشود. اما اگر یک اسم خاص بنویسیم میتوانیم هر اینترفیسی که میخواهیم را به این لیست اضافه کنیم.
خط سوم نیز تمامی درخواست های enable را به radius می فرستد با این تفاوت که روی تمامی اینترفیس ها اعمال شده و فقط از radius چک می شود. یعنی اگر radius قابل دسترس نبود از اطلاعات موجود در روتر استفاده نمی کند.
در مرحله بعد میبایست یک radius server برای روتر مشخص کنیم.

 

vCenter(config)#radius-server host 192.168.9.6  auth-port 1812 acct-port 1813 key 8888

 

که پورت 1812 برای authentication و 1813 برای Accounting مشخص شدند که اینها قرار دادی است و میتوان بسته به radius server آنها را تغییر داد. در آخر هم یک shared-key مشخص کرده ایم که در radius نیز باید آن را وارد کنیم که صرفا جهت بالا بردن ضریب امنیت است.
حال داخل line vty 0 4 مشخص میکنیم که از تنظیمات لیست shahin پیروی کند:

 

vCenter(config)#line vty 0 4
vCenter(config-line)#login authentication shahin

 

شما میتوانید از یک Radius server استاندارد مثل NttacPlus یا IBSng استفاده کنید. یک عدد RAS مشخص کنید و یک یوزر بسازید.
با آن یوزر میتوانید به روتر خود وصل شوید.
در تنظیمات دیدیم که enable نیز به radius فرستاده شد. شما میبایست یک یوزر با نام $enab15$ بسازید و یک پسورد برای آن مشخص کنید. وقتی که دستور enable را در روتر وارد میکنید روتر درخواست شما را با این یوزر به روتر خواهد فرستاد.
و آخرین نکته این که ممکن است در بعضی مواقع لینک ارتباطی شما تا radius دچار مشکل شود به همین دلیل شما قادر به ورود به روتر نخواهید بود. برای مرتفع کردن این مشکل میتوانید یک یوزر با privilege 15 بر روی روتر بسازید. با انجام تنظیمات بالا روتر ابتدا تلاش میکند که به radius متصل شود. در صورت عدم اتصال به radius به شما اجازه خواهد داد که با آن یوزر وارد روتر شوید.

 

vCenter(config)#username reza privilege 15 password 1234

 

و برای گزارش های radius از دستور زیر میتوانید استفاده کنید:

 

vCenter#show radius statistics

 

 

 

 

 


  • ۰

معرفی شبکه های نرم افزار محور SDN

معرفی شبکه های نرم افزار محور SDN

معرفی شبکه های نرم افزار محور SDN

معرفی شبکه های نرم افزار محور SDN

شبکه های نرم افزار محور (SDN) یا همان Software-Defined Networking به مانند شبکه کامپیوتری به مدیران شبکه اجازه مدیریت سرویسهای شبکه ای را از طریق یک لایه بسیار سبک را ارائه می کند. امروزه اینترنت یک جامعه دیجیتال را بوجود آورده است. به گونه ­ای که همه چیز به یکدیگر متصل­ اند و به همه چیز می­توان از هر جایی دسترسی داشت. با وجود مقبولیت­ های گسترده اینترنت­، شبکه­ های آی­پی سنتی[1] پیچیده بوده و مدیریت آنها نیز بسیار سخت می­باشد. به عنوان مثال پیکربندی شبکه طبق سیاست ­های از قبل تعیین شده سخت بوده و همچنین دوباره پیکربندی آنها به دلیل پاسخ به خرابی و یا تغییر بار شبکه نیز مشکل می­باشد­. شبکه ­های امروزی به طور عمودی مجتمع می­باشند­، به عبارتی دیگر سطوح داده[2] و کنترل[3] از یکدیگر جدا نمی­باشند. شبکه­ های نرم ­افزار محور[4] یک معماری شبکه جدیدی می­باشد که قول می­دهد اجتماع شبکه­ های امروزی را شکسته و سطوح داده و کنترل را از یکدیگر جدا نماید. به عبارت دیگر منطق کنترل شبکه را از روترها و سوییچ ­های زیرین جدا کرده و کنترل شبکه را به صورت منطقی متمرکز کرده و قابلیت برنامه نویسی (برنامه ­ریزی) شبکه را فراهم می­کند. شبکه­ های نرم­افزار محور، ساخت و معرفی انتزاع های[5] شبکه را آسان کرده­، در نتیجه مدیریت شبکه را ساده می­کند و شرایط تحول شبکه را فراهم می­کند.

در این مقاله سعی می کنیم که بررسی کاملی از شبکه های نرم افزار محور داشته باشیم. در ابتدا ضمن معرفی این شبکه‌ ها، تاریخچه این شبکه­ ها نیز بررسی شده است. و در نهایت نبز به بررسی جامع اجزای تشکیل دهنده معماری شبکه­ های نرم افزار محور و کارها و تلاش­ هایی که در خصوص استاندارد سازی این نوع شبکه ها انجام شده است، اشاره می‌کنیم.

[1]IP Networks

[2] Data plane

[3] Control Plane

[4] Software Defined Networking

[5] Abstractions

مقاله بالا که چکیده ای از آن را مشاهده می فرمایید مربوط به آقای مهندس مجید طالقانی (کارشناس ارشد شبکه­ های کامپیوتری و ارتباطی) می باشد . برای دانلود کامل مقاله اینجا کلیک نمایید.

 

 


  • ۰

حافظه های NVRAM

حافظه های NVRAM

حافظه های NVRAM

حافظه های NVRAM

روترها از حافظه فوق به منظور ذخیره و نگهداری اطلاعات مربوط به پیکربندی خود استفاده می نمایند . پس از پیکربندی یک روتر ، نتایج و ماحصل عملیات در  NVRAM ذخیره می گردد . حجم حافظه فوق در مقایسه با حافظه های RAM ، اندک می باشد. مثلا” در روترهای سری ۱۶۰۰ ، حجم حافظه فوق به هشت کیلوبایت می رسد. در روترهای بزرگتری نظیر سری ۲۶۰۰ ، حجم حافظه NVRAM به سی و دو  کیلوبایـت می رسد . پس از راه اندازی یک روتر و لود  ISO image ، فایل پیکربندی از حافظه  NVRAM  به منظور انجام پیکربندی روتر ، لود می گردد . اطلاعات موجود در این نوع از حافظه ها  ، پاک نخواهد شد (حتی زمانی که روتر Reload  و یا  خاموش است ) .

برای کسب اطلاعات بیشتر در مورد این نوع از حافظه می توانید به این لینک مراجعه فرمایید.

 

 

 

 

 

 


  • ۰

دسترسی به تجهیزات سیسکو با استفاده از CLI

دسترسی به تجهیزات سیسکو با استفاده از CLI

دسترسی به تجهیزات سیسکو با استفاده از CLI

دسترسی به تجهیزات سیسکو با استفاده از CLI

همان طور که گفته شد CLI یا همان Interface Line Common یک محیط Base Text می باشـد و شـما مـی توانیـد در این قسمت تنظیمات مختلفی را روی روتر و یا سوئیچ انجام دهید. CLI در IOS سیسکو دارای دو mode اجرایی می باشد :

user mode

• privileged mode • این بدان معنی است که برای وارد کردن تنظیمات روی روتر و یا سوئیچ می بایست وارد mode مربوطه شوید. :User Mode در این Mode می توانید عملیات محدودی را انجام دهید . در واقـع ایـن Mode پـایین تـرین سـطح دسترسـی بـه روتـر یـا سوئیچ را نشان می دهد . در این Mode عملیات Monitoring قابل اجرا است .در واقع افراد مختلف مـی تواننـد وارد ایـن Mode شده و بدون دسترسی داشتن به تنظیمات ، عملیات محدودی چون چک کردن عملکرد روتر و یا سـوئیچ را انجـام دهند.

بنابراین این Mode پایین ترین Mode از نظر سطح دسترسی خواهـد بـود . لـذا فـرامین کمتـری در ایـن Mode قابـل اجـرا خواهد بود . :Privileged Mode همانطور که از نامش پیداست ایـن Mode ، جایگـاهی بـا سـطح دسترسـی بـالاتر بـرای انجـام تنظیمـات روی روتـر و یـا سوئیچ می باشد . به صورت پیش فرض برای وارد شدن به ایـن Mode نیـازی بـه وارد کـردن پـسورد نیـست ، امـا بـرای برقراری امنیت می بایست قبل از وارد شدن به این Mode پـسورد چـک شـود تـا فقـط افـراد خاصـی بـا داشـتن پـسورد بتوانند به این Mode دسترسی پیدا کنند. بنابراین در این Mode ، دسترسی به تنظیمات روتر و یا سوئیچ و مشاهده و تغییر تنظیمات امکان پذیر می باشد .

User Mode

بعد از Boot شدن IOS و Load شدن کامل تنظیمات ، Mode User اولین جایگاهی اسـت کـه CLI نـشان مـی دهـد . در این جایگاه prompt Command به صورت زیر می باشد :

Hostname >

همانطور که گفته شد mode user یک mode با سطح دسترسی های محدود می باشد . بنـابراین در ایـن Mode شـما قادر به اجرا و به کار بردن برخی فرامین خاص هستید . به طور مثال برای اجرای بعضی گزارشات همچـون وضـعیت حافظـه و کنتـرل میـزان ترافیـک ورودی و یـا خروجـی بـه هـر اینترفیس روتر و یا سوئیچ از این مد استفاده می شود.

Hostname > show flash

 

Privileged Mode

در این mode که به آن mode enable نیز گفته می شـود، اجـازه دسترسـی کامـل بـه تمـامی فـرامین جهـت تنظیمـات بیشتر داده می شود . با وارد کردن فرمان زیر در Mode User وارد Mode Privilade خواهید شد :

Hostname > enable

با وارد کردن فرمان بالا ، prompt command به صورت زیر تغییر می کند :

Hostname #

برای خارج شدن از این mode فرمان زیر را وارد می کنید.

Hostname # exit

در mode privileged شما دسترسی به mode های دیگری چون mode global و mode interface را خواهید داشت .

در واقع در این mode هدایت کامل روتر یا سوئیچ به شما واگذار می شود .

در ادامه این فصل می آموزید که چگونه می توان با تعریف کردن password ، امنیت این mode را برقرار کرد.

 

خلاصه : در این درس با سیستم عامل روتر (IOS Cisco (و نحوه ارتباط با آن آشنا شدید . IOS سیـسکو Base Text بـوده و فاقـد محیط گرافیکی می باشد . برای دسترسی به روتر یا سوئیچ پنج روش وجود دارد . سه روش جهت دسترسـی بـه CLI و یک روش جهت ارتباط بین Server TFTP و تجیزات سیسکو و روش آخر تنظیم کردن تجیـزات سیـسکو بـه کمـک Web Browser . می باشد همچنین CLI یک محیط base-text است به طوری که دارای دو mode اجرایی زیر می باشد:

user mode •

privileged mode

• mode user یـک مـد اجرایـی محـدود اسـت و تمـامی فـرامین در ایـن مـد قابـل اجـرا نمـی باشـند در حـالی کـه mode privileged ، جایگاهی با حیطه اجرایی بالا ست و کنترل ، مدیریت و تنظیمات به صورت کلی در ایـن Mode قابل اجرا می باشند.

 

 

 

 


  • ۰

نحوه راه اندازی سوئیچ سیسکو

نحوه راه اندازی سوئیچ سیسکو

نحوه راه اندازی سوئیچ سیسکو

نحوه راه اندازی سوئیچ سیسکو

کانفیگ سوئیچ سیسکو برای راه اندازی و استفاده ، کار چندان سختی نیست ! با هم شروع کنیم …

فرض کنید یک سوئیچ سیسکو 2960 خریداری کرده اید و نیاز دارید که ابتدا یک یوزر روی آن بسازید و بتوانید با تعریف یک IP به آن تلنت کنید . یا مثلا هر پورت سوئیچ سیسکو 2960 را عضو یک VLAN نمائید ، یا یک پورت را جهت اتصال به یک سوئیچ سیسکو دیگر و یا روتر سیسکو ترانک کنید ، یا برای مثال سوئیچ شما از POE پشتیبانی میکند و میخواهید IPPhone یا IP Cam یا Wireless Radio را با آن روشن کنید …

در این مقاله سعی داریم که به شکل مقدماتی و برای رفع مقطعی مشکلات دوستان به آموزش سطحی برخی از این کاربرد ها در حد طرح کامند بپردازیم :

برای شروع ابتدا سوئیچ سیسکو را با کابل کنسول سیسکو به یک PC با پورت سریال متصل و با یک برنامه ترمینال مثل Putty به آن متصل شوید . ( میتوانید با کلیک بر روی نام putty انرا دریافت کنید )

۱- ساخت username و password و ایجاد سطح دسترسی :

switch>enable          ” ورود به محیط privilage “

switch#conf t           “وارد شدن به محیط کانفیگ “

switch(config)#aaa new-model

switch(config)#username shabake password 0 shabake

switch(config)#enable secret shabake

۲ – اختصاص دادن یک IP و default gateway به سوئیچ برای دسترسی IP :

switch(config)#int vlan 1 ( کانفیگ وی لن ۱ )

switch(config-if)#ip add 192.168.1.1 255.255.255.0 ( اختصاص آدرس )

switch(config-if)#no sh

switch(config-if)#exit

switch#vlan database

switch(vlan)#vlan 1 name shabake (ساخت وی لن ۱ )

switch(vlan)#exit

switch#conf t

switch(config)#ip default-gateway 192.168.1.2 ( آدرس روتر )

با این روش که ملاحظه کردید به راحتی میتوانید یک vlan بسازید و به آن IP اختصاص دهید ، توجه کنید که vlan 1 به شکل پیشفرض ساخته شده و تمامی پورت ها عضو vlan 1 هستند .

۳ – اختصاص هر پورت به vlan خاص :

براس مثال میخواهید چند پورت عضو Vlan خاصی باشند ، ابتدا با روش بالا vlan ها را بسازید ( Vlan database ) ، نیازی هم به اختصاص IP به هر vlan نیست ، سپس ، با روش زیر هر پورت را عضو vlan مورد نظر کنید :

switch(config)#int fas 0/1

switch(config-if)#description “connected to cisco router”

switch(config-if)#switchport access vlan 10

switch(config-if)#exit

switch(config)#int fas 0/2

switch(config-if)#description “web Server”

switch(config-if)#switchport access vlan 20

switch(config-if)#exit

ت.جه داشته باشید در هر لحظه میتوانید با دستور زیر تغییرات را زخیره کنید ، در غیر این صورت بعد از خاموش روشن کردن سوئیچ ، کانفیگی وجود نخواهد داشت !

switch#write mem

۴- کتنفیگ پورت سوئیچ سیسکو برای مود ترانک :

ترانک نوعی ارتباط است که حامل vlan هاست ! این ساده ترین نوع توضیح است ! برای مثال شما ۲ سوئیچ سیسکو دارید و روی هر سوئیچ 3 عدد vlan به شماره های 10-20-30  ، حال میخواهید nod هایی از هر سوئیچ امکان دسترسی به nod های سوئیچ دیگر که در همان vlan هستند داشته باشند .

switch-a(config)#int gi 0/1

switch-a(config-if)#description “Trunk to switch B”

switch-a(config-if)#switchport mode trunk

مشابه همین تنظیمات را در سمت دیگر نیز انجام داده و سوئیچ ها را توسط این پورت به هم متصل کنید . به همین سادگی …

۵ – استفاده از امکان POE : یکی از قابلیت های سوئیچ های سیسکو ، امکان پشتیبانی از POE یا همان استاندارد 802.3af که برق را با ولتاژ 48v به نود ارسال کرده و امکان روشن کردن دیوایس هایی که از poe پشتیبانی میکنند مثل IP Phone – IP Cam – Wireless radio  و … را دارد .

switch(config)#int fas 0/1

switch(config-if)#power inline auto

دستور فوق باعث میشود  ، در صورتی که دیوایس متصل شده به سوئیچ سیسکو قابلیت POE را دارا بود ، ولتاژ به آن ارسال شود .

خب چند نکته ، سوئیچ های سیسکو یک Vlan Database دارند که اطلاعات هر Vlan در آن ذخیره و میتوان آنرا توسط VTP ( میتوانید در مقاله ای مجزا آنرا یاد بگیرید ! ) با سایر سوئیچ های سیسکو به اشتراک گذاشت ، برای ایجاد هر Vlan حتما باید آن Vlan در vlan database موجود باشد  .

سوئیچ های لایه ۲ سیسکو قابلیت IP Routing نداشته و برای Routing میبایست از یک روتر برای inter vlan routing استفاده کرد .

سوئیچ های سیسکو به صورت پیشفرض به صورت یک سوئیچ معمولی عمل میکنند و تمامی پورت های آنها در حالت فعال و ب صورت پیشفرض عضو vlan 1 هستند ، پس میتوانید از باکس خارج کنید و به برق بزنید و استفاده کنید .

این آموزه ها فقط جنبه ابتدایی و سطحی داشته و همیشه میبایست مطالب را به صورت عمیق و کامل مطالعه فرمائید ،  دانستن کامند ممکن است ظاهرا مشکل فعلی شما را حل کند ، ولی راه حل صحیح این نیست !

 

 

 


  • ۰

معرفی Cisco IOS

معرفی Cisco IOS

معرفی Cisco IOS

معرفی Cisco IOS

 

ایــن فــصل شــامل معرفــی Device هــای سیــسکو چــون روتــر و ســوئیچ و سیــستم عامــل مخــتص بــه سیــسکو IOS Cisco و نحوه ارتباط و پیکربندی اولیه هر کدام از آنها می باشد . در انتهای ایـن فـصل مـی آموزیـد کـه چگونـه بـا Device هایی چون router و switch ارتباط برقرار کرده و آنها را جهت استفاده در یک شبکه پیکربندی کنید .

(IOS (System operating Internetwork هسته مرکزی روتر و بیـشتر سـوئیچ هـای سیـسکو چـون سـوئیچ 2950 مـی باشد . در واقع سیستم عامل روترهای سیسکو همانند دیگر سیستم عامل ها وظیفه ذخیره و بازیابی فایـل ، مـدیریت حافظه و مدیریت سرویس های مختلف را به عهده دارد . این سیستم عامل فاقد محیط گرافیکی بوده و مبتنی بـر خـط فرمان می باشد لذا دارای یک واسط کاربری UI می باشد که به کمـک آن دسترسـی بـه فـرامین و پیکربنـدی تجهیـزات سیسکو امکان پذیر می باشد. IOS در دو mode پیکربندی می شود ، mode up set و دیگری CLI . :Set UP Mode هنگامی که روتر و یا بعضی از سوئیچ های سیسکو مثل سوئیچ 2950 را برای بـار نخـست راه انـدازی مـی کنیـد وارد mode up set شده و می توانید تنظیمات اولیه چون آدرس دهی و تنظیم پسوردها را انجـام دهیـد . درواقـع یـک سـری سوالات به صورت متوالی از شما پرسیده می شود و می توانید با پاسخ دادن به هـر کـدام از آنهـا تنظیمـات اولیـه را در همین ابتدای کار انجام دهید . البته این تنظیمات کامل نخواهند بود و برای تنظیم بیشتر می بایست به Mode دیگری مراجعه کرد . همچنین می توانید به جای پاسخ دادن به این سوالات مستقیما وارد Mode Setup شوید و در هنگام نیاز این تنظیمات را انجام دهید . :(Common Line Interface) CLI (CLI (interface line-Command IOS Cisco جایگـاهی اسـت کـه مـی توانیـد تنظیمـات بیـشتری را روی روتـر و سـوئیچ انجام دهید. CLI یک محیط Base text می باشد به طوری که user در این محیط فرامین مورد نظرش را type می کند. برای دسترسی به این محیط سه روش وجود دارد که در ادامه با این سه روش آشنا می شوید.

 

 

 


  • ۰

اجزای اصلی روتر

اجزای اصلی روتر

اجزای اصلی روتر

اجزای اصلی روتر

روتر یکی از تجهیزات حیاتی است که بسته های اطلاعاتی را در مسیرهای مناسب بین شبکه ها تبادل میکند.

(IOS(InterNetwork Operating System

روتر مانند هر سیستم دیگر یک نرم افزار برای ارتباط بین کاربر و سخت افزار احتیاج دارد به آن سیستم عامل IOS میگوییم که بوسیله این سیستم عامل میتوانیم روتر را پیکربندی کنیم.
روتر از چهار حافظه اصلی زیر تشکیل شده است:

1- RAM(Random Access Memory)

2- ROM(Read Only Memory)
3- NVRAM(Non-Volatile RAM)
4- Flash

 

RAM
running configuration
حافظه غیر دائم است و زمانی که برق روتر قطع میشود حافظه نیز پاک میشود

ROM
زمانی که دستگاه میخواهد راه اندازی شود ازROM کمک میگیرد و عنصرهای زیر را در بر میگیرد
POST(Power On Self Test)
BootStrap program
rom monitor

NVRAM
start configuration
حافظه دائمی است
تنظیمات روتر را در بر میگیرد.

FLASH
IOS در flash نصب میشود.

 

 


  • ۰

آموزش راه اندازی DHCP سرور بر روی روتر و سوییچ سیسکو

آموزش-راه-اندازی-DHCP-سرور-بر-روی-روتر-و-سوییچ-سیسکو

اگر به دنبال این هستید که برای استفاده کلاینت های شبکه خود از سرویس DHCP استفاده کنید ، چندین راهکار وجود دارد . معمولا در اکثر شبکه ها از یک سرور ویندوزی یا لینوکسی به عنوان DHCP سرور استفاده می شود و یا از همان مودم DSL یا روتر اینترنت به عنوان DHCP سرور استفاده می شود . اکثر مدیران شبکه حتی فکر این را نمی کنند که از تجهیزات سیسکو مانند روتر و سویچ سیسکو می توانند به عنوان DHCP سرور استفاده کنند . البته فراموش نکنید که این قابلیت با نسخه های جدید از IOS های سیسکو ارائه شده است و با سری محصولات Catalyst 3550 و 3750 ارائه شده است . اولین کار این است که در نظر بگیریم که آیا این راهکار به درد سازمان ما می خورد یا خیر . استفاده از روتر و سویچ به عنوان DHCP سرور مزایا و معایت خاص خود را دارد . مثلا فرض رو بر این بگیرید که شبکه ای دارید که بصورت ترکیبی شامل چندین شبکه است و شما میخواهید توسط یک روتر به کلیه آنها آدرس دهی کنید .

یکی از مزایای استفاده از روتر و سویچ به عنوان DHCP سرور این است که نیاز به سخت افزار اضافی ندارد و هزینه اضافی برای شما در بر نخواهد داشت ، بر خلاف اینکه در صورت استفاده از یک سرور ویندوزی حتما به سخت افزار اضافه نیاز خواهید داشت و این برای سازمان شما یعنی هزینه اضافی .از معایب این راهکار این است که برخی از مدیران شبکه برای مانتیورینگ و نگهداری روتر دچار مشکل هستند و با رابط کاربری خط فرمانی آن دچار مشکل هستند و این خود یکی از مهمترین دلایل استفاده نکردن از این راهکار محسوب می شود.خوب این طبیعی است که مدیریت و نگهداری یک محیط گرافیکی مانند ویندوز سرور بسیار راحتتر و آسانتر از دستورات IOS سیسکو است . اما در کل این راهکار بسیار برای مدیران شبکه کارآمد و مفید است . خوب بریم سراغ انجام تنظیمات ، ما تنظیمات رو بر حسب یک IOS جدید انجام میدیم که تنظیمات بصورت پیشفرض قرار داشته باشه ، خوب یک راست بریم سراغ اصل ماجرا ، به روتر یا سویچ متصل می شیم و بر اساس مراحل زیر جلو میریم :

1-روی یکی از interface های روتر یک IP استاتیک تعریف می کنیم و بعد inerface را up می کنیم :

1
2
3
Router(config)# interface ethernet0/0
Router(config-if)#ip address 1.1.1.1 255.0.0.0
Router(config-if)# no shutdown

2- خوب حالا یک address pool یا به قول ما ویندوزی ها Scope تعریف می کنیم:

1
Router(config)# ip dhcp pool mypool

3- خوب subnet mask رنج IP مورد نطرتون رو در ادامه وارد کنید ، روتر این رنج رو به درخواست هایی که بهش میرسه اختصاص میده :

1
Router(dhcp-config)# network 1.1.1.0 /8

4-خوب نام دامنه یا دامین را به DHCP سرور معرفی میکنیم :

1
Router(dhcp-config)#domain-name itpro.ir

5-خوب آدرس Primary و Secondary مربوط به DNS سرور رو هم به روتر معرفی میکنیم :

1
Router(dhcp-config)#dns-server 1.1.1.10 1.1.1.11

6-آدرس روتر یا Default Gateway رو در مرحله بعد اضافه می کنیم :

1
Router(dhcp-config)#default-router 1.1.1.1

7-خوب زمان Lease یا همون Lease Duration رو هم بهش اضافه می کنیم :

1
Router(dhcp-config)#lease 7

8-از حالت configuration mode خارج می شویم :

1
Router(dhcp-config)#exit

با این دستور مجددا به حالت global configuration وارد می شی و می تونی آدرس هایی رو که مد نظرت هست رو exclude کنی ، در این حالت وقتی DHCP سرور می خاد آدرس دهی کنه از این رنج برای کلاسنت ها استفاده نمی کنه و ما می تونیم به عنوان استاتیک IP برای سرور ها مون از این رنج استفاده کنیم .


9-خوب با دستور زیر 100 تا آدرس اول رنج IP رو exclude میکنیم .

1
Router(config)#ip dhcp excluded-address 1.1.1.0 1.1.1.100

خوب حالا تنظیمات کامل شده شما میتونی براحتی با استفاده از دستور ipconfig /renew آدرس IP کلاینت رو مجددا از DHCP درخواست کنید.

امیدوارم از این پست لذت برده باشید.


  • ۰

مراکز داده در ایران

مراکز داده در ایران

دیتاسنتر مرکز داده ای است که نقش استراتژیکی در پیش برد برنامه های اطلاع رسانی و ارتباطی دیجیتالی در یک جامعه اطلاعاتی بازی می کند. همان طور که می دانید ، داده می تواند به صورت های متنی ، صوتی ، تصویری و … باشد . مانند درایو رایانه که امکان فراخوانی فایلهای فولدرهای مختلف را فراهم می کند ؛ دیتا سنتر نیز چنین رفتار فنی دارد با این تفاوت که معمولا دیتاسنترها به شبکه های بومی و بین المللی متصل هستند. این مراکز داده مراکزی به شمار می آیند که از بهم پیوستن مجموعه ای از تجهیزات سخت افزاری و نرم افزاری جهت نگهداری و پشتیبانی و میزبانی (Hosting) پایگاه های اطلاع رسانی تحت وب ، مورد استفاده قرار می گیرد. نوع سخت افزار به کار رفته در دیتا سنترها و نوع سیستم عامل و برنامه های نرم افزاری پشتیبانی و امنیتی و تجارتی خاصی که روی آن قرار گرفته است ، ارزش و قابلیت آن را برای مصرف کننده و درنهایت end user در پی خواهد داشت . مقایسه مراکز داده در ایران وکشورهای پیشرفته جهان هدف ما را در پیشبرد اهدافمان در حوزه فناوری اطلاعات مشخص خواهد کرد.

طراحی-و-راه-اندازی-دیتاسنتر-مشاوره-دیتاسنتر-استاندارد-های-دیتاسنتر-DataCenter-ISO27001

دیتاسنتر های استاندارد بین المللی ISO

EQ_IMG_Data-Center-Colo_Standards_ISO_ISO-Logo_140x105
استاندارد ISO بزرگترین سازمان تولید کننده استاندارد های بین المللی در کلیه حوزه ها می باشد. گواهینامه ISO به منزله اینست که محصول یا سرویس ارائه شده به مشتری کلیه پارامتر های مشخص شده استاندارد شامل کیفیت ، اجرا ، امنیت ، ایمنی و استاندارد های محیطی و انرژی را دارا می باشد و به پذیرش اداره استاندارد رسیده است.

گواهینامه ها

ISO 9001:2008 Quality Management Systems Standard

ISO 14001:2004 Environmental Management System Standard
OHSAS 18001: 2007 Occupational Health & Safety Management System Standard
ISO / IEC 27001:2005 and 27001:2013 Information Security Management System Standard
ISO 50001:2011 Energy Management System Standard
PCI-DSS Payment Card Industry Data Security Standard

data-center-services-خدمات-دیتاسنتر

 


آخرین دیدگاه‌ها

    دسته‌ها