روش ساده برای کاهش مشکل DNS Timeout های متعدد

  • ۰

روش ساده برای کاهش مشکل DNS Timeout های متعدد

روش ساده برای کاهش مشکل DNS Timeout های متعدد

DNS یکی از مهمترین پایه های یک شبکه می باشد و درصورت اختلال در عملکرد سرویس DNS بسیاری از سرویس ها مختل خواهند شد . DNS Timeout های متعدد سرعت سرویس دهی شبکه را کاهش می دهد، در این مطلب ترفند ساده ای را برای کاهش تعداد DNS Timeout در یک شبکه را آموزش خواهیم داد.

روش ساده برای کاهش مشکل DNS Timeout های متعدد

روش ساده برای کاهش مشکل DNS Timeout های متعدد

زمانی که از طریق سرویس DHCP می‌خواهید به کاربران خود IP address تخصیص دهید بهتر است در قسمت DNS آدرس DNS داخلی خود را دو بار وارد کنید، تا زمانی که از طرف کاربر درخواستی ارسال می‌شود به علت ضعیف بودن شبکه با Timout مواجه نشود، یعنی اینکه اگر بر روی DNS اول Timout دریافت کرد در DNS دوم بتواند اطلاعات را دریافت کند، مثلاً در میکروتیک DNS را به صورت زیر وارد می‌کنیم:

روش ساده برای کاهش مشکل DNS Timeout های متعدد

در شکل بالا آدرس 172.16.1.7 آدرس سرور داخلی است که در این قسمت دوبار تعریف شده است تا زمانی که کلاینت برای سرور داخلی درخواست می فرستد با مشکل مواجه نشود، موفق باشید.

 

 

 

 


  • ۰

جدا سازی پهنای باند شبکه داخلی از اینترنت در میکروتیک

جدا سازی پهنای باند شبکه داخلی از اینترنت در میکروتیک

جدا سازی پهنای باند شبکه داخلی از اینترنت در میکروتیک

جدا سازی پهنای باند شبکه داخلی از اینترنت در میکروتیک

در میکروتیک هنگامیکه کاربران به سرور pppoe  متصل میشوند queue دینامیک برایشان با توجه به گروه انتخابی ایجاد میشود.بطور مثال گروه ۱۲۸k .حالا مشکلی که ممکنه بوجود بیاد اینه که دسترسی کاربران به سرورهای داخلی مثل سرور ftp یا file server محدود میشه به ۱۲۸k .در این سناریو میخوام دسترسی به سرور داخلی ftp نامحدود ولی دسترسی به اینترنت همون ۱۲۸k باشه.

فرض میکنیم ۱۹۲٫۱۶۸٫۱٫۰/۲۴ رنج ip کاربران pppoe باشه و ۱۹۲٫۱۶۸٫۲٫۱ ip سرور ftp.

حالا دستورات زیر رو در میکروتیک وارد کنید :

1
2
3
4
5
6
7
8
9
/ip firewall mangle add chain=prerouting src-address=192.168.1.0/24 dst-address=192.168.2.1 action=mark-packet new-packet-mark=ftp-up
/ip firewall mangle add chain=postrouting dst-address=192.168.1.0/24 src-address=192.168.2.1 action=mark-packet new-packet-mark=ftp-down
/queue type add name=ftp-exempt kind=sfq
/queue tree add name=ftp-up parent=global-in packet-mark=ftp-up queue=ftp-exempt max-limit=100M
/queue tree add name=ftp-down parent=global-out packet-mark=ftp-down queue=ftp-exempt max-limit=100M

من در نسخه ۵٫۲۶ تست کردم و کاملا درست کار کرد.


آخرین دیدگاه‌ها

    دسته‌ها